>
常用交换机状态查询命令

 

实验九   交换机基本配置
1.     掌握交换机在网络中的作用、组成以及交换机设备选型;
2.     掌握PacketTrace 仿真软件的使用方法;
3.     练掌握交换机的基本配置命令,包括交换机名称设定、保护口令设定、口令封装、接口描述、查看命令等。
 Cisco2621 Switch、Cisco 2950 交换机、PacketTrace仿真软件、具备Windows操作系统的PC机
重点:掌握PacketTrace路由仿真软件的使用、交换机基本配置
 
 
 
 
 
 
 
 
 
 
 
 
 
 
一、交换机功能
在局域网交换技术中,共享式以太网、冲突域、广播域、桥接、交换、MAC 地址表、VLAN、
VLAN 中继等概念特别重要。下面对这些概念做一下简单回顾。
1. 共享式以太网
共享式以太网是构建在总线型拓扑上的以太网,严格遵从载波侦听多路访问/冲突检测
CSMA/CD, Carrier Sense Multiple Access/Collision Detect)算法的网络,CSMA/CD 算
法的机制决定了共享式网络的半双工特点。在共享式以太网上,当一台主机发送数据的时候
其他主机只能接收该以太网帧,此时网上其他主机都不能发送数据。
2. 冲突域
用同轴电缆构建或以hub 为核心构建的共享式以太网,其上所有节点同处于一个冲突
域,一个冲突域内不同设备同时发出的以太网帧会互相冲突;同时,冲突域内的一台主机发
送数据,同处于一个冲突域的其他主机都可以接收到。
3. 广播域
广播域是网上一组设备的集合,当这些设备中的一个发出一个广播时,所有其他设备都
能接受到这个广播帧。
广播域和冲突域是比较容易混淆的概念,我们可以这样区分他们:连接在一个hub 上的
所有设备都处于一个冲突域,同时也构成了一个广播域;连接在一个没有划分VLAN 交换机
上各端口上的设备处于不同的冲突域中(每一个交换机的端口构成了一个冲突域),但同属
于一个广播域。
4. 桥接
所谓桥接,CCNA 中主要是指透明桥接。透明网桥连接两个或者更多的共享以太网网段,
不同的网段分别属于各自的冲突域,所有网段处于同一个广播域。桥接工作模式应认真理解,
它是理解交换机工作原理的基础。
5. 交换
局域网交换的概念源自桥接,它与透明网桥使用相同的算法,只是交换的实现是用专用
硬件实现,而传统的桥接是用软件来完成的。
6. MAC 地址表
交换机内有一个MAC 地址表,用于存放该交换机端口所连接设备的MAC 地址与端口号的
对应信息。MAC 地址表是交换机正常工作的基础,我们应该了解它的生成过程。
7. VLAN
VLAN 用以把物理上直接相连的网络从逻辑上划分为多个子网。每一个VLAN 对应着一个
广播域。
二层交换机没有路由功能,不能在VLAN 之间转发帧,因而处于不同VLAN 上的主机不能
进行通信,只有引入第三层交换(VLAN 间路由)技术之后,VLAN 间的通信才成为可能。
8. VLAN 中继
VLAN 中继(VLAN Trunk)也称为VLAN 主干,是指在交换机与交换机之间或者交换机与
路由器之间连接的情况下,在互相连接的端口上配置中继模式,使得属于不同VLAN 的数据
帧都可以通过这条中继链路得以传输。
VLAN 中继的帧格式分为ISL 和IEEE802.1Q 两种,其中前者是Cisco 交换机独有的协议,
后者是国际标准,被几乎所有的设备厂商所广泛支持。
9. VLAN 中继协议
对于Cisco 设备而言, VLAN 中继协议即VTP 协议可以帮助交换机设置VLAN.VTP 协议可以维护VLAN 信息的全网一致性.
VTP 有三种工作模式,即服务器模式,客户模式和透明模式,对于三种模式的准确区分是
交换技术需要掌握的要点之一。
二、PacketTrace 使用
打开PacketTrace软件,选择“Custom Made Devices”中的2621XM系列交换机。再选择“Connections”连接线中的“Serial DCE” 连接线,按照如图交换机的方式连接好交换机。然后,按照图示连接好交换机和主机。
三、交换机配置
1.交换机配置模式及其转换
⑴ 用户模式(user mode)                              switch>
用户模式(user mode):该模式下只能查看交换机基本状态和普通命令,不能更改交换机配置。此时交换机名字后跟一个“>”符号,表明是在用户模式下。如:switch>
⑵ 特权模式(privileged mode)                          switch#
特权模式(privileged mode):该模式下可查看各种交换机信息及修改交换机配置。在用户模式下以enable命令登陆,此时“>”将变成“#”,表明是在privileged mode .如:switch#
⑶ 全局配置模式(golbal configuration mode):       switch(config)#
全局配置模式(golbal configuration mode):该模式下可进行更高级的配置,并可由此模式进入各种配置子模式。其提示符如:switch(config)#
⑷ 从各模式下返回,只要不断输入exit即可
 
2.按照地址表配置交换机各接口的地址信息
⑴ 配置与LAB_B直连的交换机B
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname 2950B
2950B(config)#enable secret todd
2950B(config)#line con 0
2950B(config-line)#login
2950B(config-line)#password console
2950B(config-line)#line vty 0 15
2950B(config-line)#login
2950B(config-line)#password telnet
2950B(config-line)#banner motd #
Enter TEXT message. End with the character '#'.
This is my 2950B switch
#
2950B(config)#
2950B(config)#int f0/4
2950B(config-if)#desc connection to 2950C
2950B(config-if)#int f0/5
2950B(config-if)#desc 2nd connection to 2950C
2950B(config-if)#int vlan 1
2950B(config-if)#ip address 172.16.10.3 255.255.255.0
2950B(config-if)#no shut
2950B(config-if)#exit
2950B(config)#ip default-gateway 172.16.10.1
2950B(config)#exit
2950B#copy run start
Destination filename [startup-config]? [Enter]
Building configuration...
[OK]
2950B#
2950B#ping 172.16.10.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.10.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/4 ms
2950B#
 
⑴ 配置与LAB_C直连的交换机C
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname 2950C
2950C(config)#enable secret todd
2950C(config)#line con 0
2950C(config-line)#login
2950C(config-line)#password console
2950C(config-line)#line vty 0 15
2950C(config-line)#login
2950C(config-line)#password telnet
2950C(config-line)#banner motd #
Enter TEXT message. End with the character '#'.
This is my 2950C switch
#
2950C(config)#int f0/1
2950C(config-if)#description Connection to router
2950C(config-if)#interface f0/4
2950C(config-if)#description Connection to 2950B
2950C(config-if)#int f0/5
2950C(config-if)#description 2nd connection to 2950B
2950C(config-if)#int vlan1
2950C(config-if)#ip address 172.16.10.2 255.255.255.0
2950C(config-if)#no shut
2950C(config-if)#exit
2950C(config)#ip default-gateway 172.16.10.1
2950C(config)#^Z
2950C#copy run start
Destination filename [startup-config]? [Enter]
Building configuration...
[OK]
四、常用交换机状态查询命令(在特权模式下输入命令)
show version         //查看IOS版本号,已启动时间,flash中的IOS的文件名,switch里面共有什么的端口,寄存器的值等等。
show flash           //查看flash中的内容,IOS的长度,文件名,剩余空间,总空间。
show running-config //查看交换机当前的配置信息。
show startup-config //查看nvram 中的交换机配置信息。
show mac-address-table       //查看交换机上的各个端口的状态信息。(很多重要信息)



上一篇:IOS配置文件上传与下载操作
下一篇:VLAN Trunk的作用并掌握其设置

相关文章: 无相关信息
热门文章:
  • ·H3C交换机查看光功率、收发光情况的命
  • ·Mac OS X 通过Terminal和shell修改DNS
  • ·无线路由器的设置使用方法
  • ·常用交换机状态查询命令
  • ·巧设无线路由获得更稳定信号
  • ·CISCO路由器的端口聚合功能详解
  • ·H3C 交换机的基础配置和命令行与无线路
  • ·云主机配置OpenStack使用spice的方法
  • ·VMware VSAN 入门与配置VSAN网络和集群
  • ·ups连接输入输出电缆注意事项
  • ·CISCO Switch port-channel追加vlan设
  • ·文件服务器安装与配置Windows Server

  • 发表点评 共有条点评
    会员 内容 时间
    用户名: 密码:
    验证码: 匿名发表
    测试站点注册
    用户名:
    密  码:
      忘记密码?
    常见问题
    最新测试